Mon compte




What are the pre-requisites for renting a Connect car?

1/ You must have a smartphone equipped with a camera, Bluetooth, and one of the following operating systems:

- iOS: a minimum of iOS version 8.0 (iPhone 4S and above);
- Android: a minimum of Android version 4.3 (all models).

2/ You must download our OuiCar app, which is available from the Apple Store or the Play Store.

Naturally, you must also comply with the insurance terms and conditions, which apply to all our services.

Was this article helpful?
5 out of 7 found this helpful
Have more questions? Submit a request

Powered by Zendesk